Critical Drupal security update

Critical Drupal security update

Drupal has released a critical security update to address a vulnerability in Drupal 7.x, 8.5.x and 8.6.x. The vulnerability is rated critical and impacts third party libraries.

Drupal released the security update (SA-CORE-2019-001) for a Drupal core third party library PEAR Archive_Tar. The update impacts some Drupal configurations.

An excerpt of the critical Drupal vulnerability (CVE-2018-1000888), as provided by NIST:

“PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with $v_header['filename'] as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with phar://[path_to_malicious_phar_file] as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because @unlink($this->_temp_tarname) is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.”

Drupal recommended these solution upgrades to address the vulnerability:

  • Running Drupal 8.6.x: upgrade to Drupal 8.6.6.
  • Running Drupal 8.5.x or earlier: upgrade to Drupal 8.5.9.
  • Running Drupal 7.x: upgrade to Drupal 7.62.

Remote attackers could exploit this Drupal vulnerability to take control of unpatched systems.